I ran across this error message when trying to run the uninstaller:

user@ubuntu:~$ sudo /usr/local/domy-uninstaller
[sudo] password for user:
Error: There has been an error.
The domy-uninstaller.dat file cannot be found and is required to uninstall the
application, aborting
Uninstallation did not complete successfully

This message is in error because here's a listing with permissions of the folder:

user@ubuntu:/usr/local$ ls -l
total 4184
drwxr-xr-x  2 root root   12288 Aug 24 03:27 bin
drwxr-xr-x  9 root root    4096 Aug 24 03:24 doc
-rwx------  1 root root 4153260 Aug 24 03:25 domy-uninstaller
-rw-r--r--  1 root root   78248 Aug 24 03:25 domy-uninstaller.dat
drwxr-xr-x  4 root root    4096 Aug 24 03:25 etc
drwxr-xr-x  2 root root    4096 Apr 23 04:34 games
drwxr-xr-x  2 root root    4096 Aug 24 03:25 include
drwxr-xr-x 11 root root    4096 Aug 30 04:12 lib
lrwxrwxrwx  1 root root       9 Jun  4 07:54 man -> share/man
drwxr-xr-x  2 root root    4096 Aug 24 03:25 sbin
drwxr-xr-x  9 root root    4096 Aug 24 03:24 share
drwxr-xr-x  9 root root    4096 Aug 24 03:26 src
-rwxr-xr-x  1 root root     167 Aug 24 03:25 Uninstall Do Moses Yourself.desktop
user@ubuntu:/usr/local$

How can I force the uninstaller to see/use the uninstaller.dat file?

asked 31 Aug '12, 09:53

tahoar's gravatar image

tahoar
201313236
accept rate: 42%


Could you execute the uninstaller as:

domy-uninstaller --debugtrace debug.txt

And send us the generated file to support@bitrock.com?

link

answered 01 Sep '12, 07:37

juanjo's gravatar image

juanjo ♦♦
5.8k413
accept rate: 23%

I ran "domy-uninstaller --debugtrace debug.txt". It reported the exact same error message as above. Debug.txt file was not generated and there was no uninstaller log file in the /tmp folder. I neglected to mention before that this is IB version is 8.5.0-201208061419 running on 32-bit Ubuntu Linux. There might be a problem with the host system. I'll rebuild and re-install from scratch. I'll report if the problem reappears.

(01 Sep '12, 10:06) tahoar

Regrettably, I learned our users was trying to run the 64-bit installer on a 32-bit platform with "sudo" privileges. This corrupted underlying host system. He rebuilt the host and changed to the 32-bit installer, which ran fine. Is there a way to update the 64-bit installer to test and abort under this condition?

(15 Oct '12, 22:01) tahoar
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×83

Asked: 31 Aug '12, 09:53

Seen: 7,641 times

Last updated: 15 Oct '12, 22:01