When using BitRock auto update tool, specifying an http:// address either in update.ini or in the location of retrieved XML settings, causes the installer to show a message:

Unable to contact update server. Update Not Available

What has to be done to enable SSL?

asked 11 Oct '12, 09:47

wojciechka's gravatar image

wojciechka ♦♦
7.8k61122
accept rate: 26%


By default, both installers and autoupdate binaries do not include SSL support because of binary sizes (SSL is not always required and it adds up around 500kB to binary).

SSL support has to explicitly enabled by specifying <enableSslSupport> in the <autoUpdateProject>.

<autoUpdateProject> ... <enableSslSupport>1</enableSslSupport> <sslCAFile>path/to/organization.ca</sslCAFile> </autoUpdateProject>

The optional <sslCAFile> will cause InstallBuilder and/or autoupdate tools to use specified CA file to verify SSL certificate's authenticity - this allows making sure that the SSL connection is only made to site with a valid SSL certificate. The same tags can be specified for InstallBuilder installer project to enable SSL support.

Creating customized autoupdate binaries is documented in more details in Autoupdate documentation

link

answered 11 Oct '12, 09:49

wojciechka's gravatar image

wojciechka ♦♦
7.8k61122
accept rate: 26%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×52
×5

Asked: 11 Oct '12, 09:47

Seen: 1,787 times

Last updated: 11 Oct '12, 09:49