I need to rearrange the installers within a different directory structure. To avoid duplicating the copies of files I use symlinks, but found out the installer can't be launched through symlinks. Why the limitation? Can it it fixed?

The problem exists on both Windows and Linux. On Linux, I got the following error: Error: There has been an error. Installer payload initialization failed. This is likely due to an incomplete or corrupt downloaded file.

On Windows 7 I use mklink command to create the symlink, there is no response when I run the symlink

asked 16 Oct '12, 19:44

gt8967884's gravatar image

gt8967884
101747678
accept rate: 12%


Regarding symlinks on Linux, they currently do not work properly for relative path symlinks containing .. - such as ../installer.run. However, they work fine for absolute paths - such as specifying it as /path/to/installer.run - and symbolic links without ... Could you simply change the symlink to be absolute?

As for mklink command, can you provide us with your exact setup - Windows version, path to installer and exact mklink command?

Creating a symlink with mklink and creating a hard link with fsutil hardlink worked fine for us.

link

answered 17 Oct '12, 05:36

wojciechka's gravatar image

wojciechka ♦♦
7.8k61122
accept rate: 26%

On Linux the symbolic to absolute path worked, but we need to move the files from a build machine to some network location, so absolute path is not desired. Is it possible to fix the symlink to relative path?

(17 Oct '12, 15:46) gt8967884

On Windows, I tried both relative and absolute path, the installation can go through, but failed at creating uninstaller part with Warning "Problem creating uninstaller. Installation may have not completed comrrectly. Unable to create uninstaller".

The command I use:

mklink tt.exe ..\output\demo-1.0-windows-installer.exe
10/17/2012  12:37 PM    <symlink>      tt.exe [..\output\demo-1.0-windows-installer.exe]

mklink tta.exe c:\bitrock\output\demo-1.0-windows-installer.exe 10/17/2012 12:39 PM <symlink> tta.exe [c:\bitrock\output\demo-1.0-windows-installer.exe]

(17 Oct '12, 15:46) gt8967884

Regarding Windows, thank you for more detailed information. Indeed, there are subtle differences with symlinks on Windows and this causes the uninstaller not to get created properly. We have fixed the issue. Please contact support@bitrock.com and we will provide you with a fix for this.

Regarding Linux, we are investigating options to fix the issue, unfortunately the issue is in one of our underlying libraries - we have reported it, but fixing it will take some time. So for now the only options are hardlinks (which work fine) or symlinks with absolute paths.

(18 Oct '12, 04:44) wojciechka ♦♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×6

Asked: 16 Oct '12, 19:44

Seen: 1,761 times

Last updated: 18 Oct '12, 04:44