When running the uninstaller generated for our project everything works great except the last string that is shown above the progress bar is:

"${product_fullname} has been uninstalled."

All of the other references to product_fullname are correct in the uninstaller, it's just this one string.

I can't find any information on how these strings are created for uninstaller (i know you can see the strings for the installer in the file en.lng), but i can't find any uninstaller strings.

Is there anything i need to keep around for this variable reference to be correct in the uninstaller?

asked 28 Nov '12, 13:52

meflynn's gravatar image

meflynn
1667
accept rate: 0%


That is very strange. Is that the exact error displayed? Could you send us your project to support@bitrock.com?

link

answered 28 Nov '12, 15:17

juanjo's gravatar image

juanjo ♦♦
5.8k413
accept rate: 23%

I have figured out what the issue is. We had changed our custom-en.lng so the string for the entry Installer.Uninstallation.Completed so it was set to

Installer.Uninstallation.Completed={$product_fullname} has been fully uninstalled.

It seems that at this point in uninstallation (pretty much the end) there is no more reference to this variable.

link

answered 13 Dec '12, 17:37

meflynn's gravatar image

meflynn
1667
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×83
×1

Asked: 28 Nov '12, 13:52

Seen: 940 times

Last updated: 13 Dec '12, 17:37