Why does the showChoiceQuestion dialog appear off-screen during post-installation actions?

We have installbuilder version 8.2.0 and in the postInstallationActionList, I have a choice question dialog display using showChoiceQuestion to get some information from the user.

I am testing out installbuilder verision 8.5.1 to see if it is safe to upgrade, and when I do, I have the problem that the showChoiceQuestion dialog does not get displayed in the normal position (in front of the setup window). Instead, the dialog is somewhere off-screen and the only way to get at it is to right-click on the icon in the task bar and select move, then use arrow keys to guide it back. This problem does seem to only occur on systems with multiple monitors. I am using Windows 7.

I notice that in the changelog, version 8.5.0 has a fix for "Fixed <showquestiondialog> dialog failing in some environments", and I wonder if the showChoiceQuestion could be having a similar problem.

Thanks.

asked 22 Jan '13, 17:19

Karl's gravatar image

Karl
1111
accept rate: 0%


Could you write us to support@bitrock.com? That may be because of a bug we recently solved and will be soon released. In the meantime we will create a build for you.

link

answered 22 Jan '13, 17:28

juanjo's gravatar image

juanjo ♦♦
5.8k413
accept rate: 23%

OK, I'll do that.

link

answered 23 Jan '13, 18:32

Karl's gravatar image

Karl
1111
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×176
×4

Asked: 22 Jan '13, 17:19

Seen: 1,399 times

Last updated: 23 Jan '13, 18:32