I am able to successfully uninstall and remove the content of the files inside my application folder. But i am not able to delete the Folder itself.

        <postUninstallationActionList>
            <deleteFile>
              <path>${installdir}</path>
            </deleteFile>
    </postUninstallationActionList>
    <preBuildActionList>

what is am i missing ?

asked 26 Jan '16, 15:11

ropo18's gravatar image

ropo18
1556
accept rate: 0%


Is there any other file inside the installdir that is not being deleted (visible or hidden)? Please note that, on Windows, InstallBuilder won't be able to delete a folder if it is not empty.

link

answered 28 Jan '16, 09:21

alejandror's gravatar image

alejandror ♦♦
1.3k127
accept rate: 31%

edited 28 Jan '16, 09:22

there are no other folders / files under {installdir}

link

answered 28 Jan '16, 11:27

ropo18's gravatar image

ropo18
1556
accept rate: 0%

Hi ropo18,

Could you check if there are any process running in your machine that are using that folder?

(29 Jan '16, 13:11) jesus ♦♦

I had the same problem. I find out that it was caused by uninstall log file. Turning off creation of the uninstall log fixed this problem for me.

link

answered 18 Jan, 06:41

Filip%20Matiovsk%C3%BD's gravatar image

Filip Matiovský
612
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×9

Asked: 26 Jan '16, 15:11

Seen: 941 times

Last updated: 18 Jan, 06:41