Hi,

We are using Bitrock version - 15.10.1, in OSX platform.

Our requirement is to check whether our application '${installdir}/launch.app' is running or not. We were using 'File is locked' object and it was working perfectly in Windows. Now we tried the same in OSX, it is not working.

We cant use 'Process Test' object because we need to check the application present in '${installdir}/launch.app'. 'Process Test' object may return true even if our application is running in different directory. As per our requirement we need to check whether the application in the installed location is running or not.

Please help us in fixing the issue.

Thanks you

asked 22 Mar '16, 11:52

Manoj_Ram's gravatar image

Manoj_Ram
30202122
accept rate: 25%


Hi Manoj_Ram,

Unfortunately, the <isfilelocked> rule is only supported on Windows and Linux. Our recommendation is to use a runProgram that executes the ps command to check if a given path is presented or not.

<setInstallerVariableFromScriptOutput>
    <name>ps_output</name>
    <exec>ps</exec>
    <execArgs>aux | grep ${installdir}/launch.app</execArgs>
</setInstallerVariableFromScriptOutput>
<actionGroup>
        <actionList>
        ...
        </actionList>
        <ruleList>
            <stringTest>
                    <text>${ps_output}</text>
                    <type>empty</type>
            </stringTest>
        </ruleList>
</actionGroup>
link

answered 23 Mar '16, 04:47

jesus's gravatar image

jesus ♦♦
1.1k14
accept rate: 18%

Thanks you for your help.

It worked but the 'STRING TEST' in the 'ruleList' is incorrect. Because the output of the command 'ps aux | grep ${installdir}/launch.app' will never be an empty string. We modified the 'ruleList' as below and it worked perfectly

                <ruleList>
                    <compareText>
                        <logic>contains</logic>
                        <text>${ps_output}</text>
                        <value>${installdir}/launch.app/Contents/</value>
                    </compareText>
                </ruleList>

Thanks once again..

link

answered 23 Mar '16, 17:36

Manoj_Ram's gravatar image

Manoj_Ram
30202122
accept rate: 25%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×130
×2

Asked: 22 Mar '16, 11:52

Seen: 404 times

Last updated: 23 Mar '16, 17:36