Trying to install a .app made and signed with Bitrock. On target machine (OS X 10.9, 10.10, 10.11.3) the app is rejected. "App is damaged and can't be opened".

To reproduce: Install apple update to 10.11.4. Start with sample project. Add code signing and DMG creation. Build an app with code signing that worked previously. Try to install on test machines.

Using Bitrock 15.10.1. Tried with an evaluation version of Bitrock 16 and same failure occurred.

asked 09 May '16, 11:54

davidr's gravatar image

davidr
1111
accept rate: 0%


Sorry for the late reply. It seems Apple has changed how the signature is verified and it may be failing depending on the platform in which the installer is signed. We have checked that the InstallBuilder built-in method for code signing still works properly. Could you check if it works for you? You can find more information about this method in this link to the documentation.

link

answered 08 Jun '16, 09:24

alejandror's gravatar image

alejandror ♦♦
1.3k127
accept rate: 31%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×130
×10

Asked: 09 May '16, 11:54

Seen: 560 times

Last updated: 08 Jun '16, 09:24