I have a multi-platform installer that has worked fine for all Windows and Mac platforms, until Mac Sierra. The installer worked on the target machine under an account running Mac El Capitan, so the previously installed app was resident on the machine when it was upgraded to Mac Sierra.

When I download, unzip, and run the installer on Sierra, this error occurs:

'...Installer payload initialization failed...'

When I open a command-prompt, navigate to installbuilder.sh and call it like this:

sudo ./installbuilder.sh

it works. What's different about Sierra that's causing this problem?

I tried chmod -R 777 on the entire installer folder. I tried moving the installer folder /Applications folder.

Thank you in advance for any assistance.

asked 17 Oct '16, 12:39

jl01's gravatar image

jl01
1223
accept rate: 0%


link

answered 18 Oct '16, 05:08

Guy%20Linksman's gravatar image

Guy Linksman
169912
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×130
×22
×2
×1

Asked: 17 Oct '16, 12:39

Seen: 680 times

Last updated: 18 Oct '16, 05:08