Hello,

I noticed that on OSX the java updates are not supported for install applications with install builder. for example :

Example 1: My java application calls a webservice in https, since this weekend i have changed the ssl certificate for a certificate let's encrypt. The let's encrypt root certificate is present only on the latest java versions. So I updated the jdk and jre (1.8.0.121 which supports let's encrypt) on the mac. When I run my jar in command line it works perfectly, para, if I run it via the binary generated by installbuilder I get a certificate error. Only solution, to reinstall my application completely with linstallbuilder.

Example 2: If during installation, the computer does not contain a java I install the embed version, but if I subsequently install a version on the system, the binaries generated by install builder does not use this version

With Windows no problem the latest version installed is used.

How to have the same behavior on OSX? Is this a bug?

best regards

asked 20 Mar, 18:15

devildant's gravatar image

devildant
1336
accept rate: 0%

Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×90
×1

Asked: 20 Mar, 18:15

Seen: 25 times

Last updated: 20 Mar, 18:15