HttpGet does not seem to be able to connect to the server which is using https. Is it supposed to work? Also - will it work if the server is using self-signed certificate?

asked 29 Mar, 13:07

Anna_G's gravatar image

Anna_G
62
accept rate: 0%


To use https You need to enable ssl support <enableSslSuport>1</enableSslSupport>. It will work with a self-signed certificate.

link

answered 30 Mar, 06:34

Michiel's gravatar image

Michiel ♦
82114
accept rate: 22%

Where do I set <enablesslsuport>1</enablesslsupport>? I am not able to set it inside <httpget>. I am able to set it on the project level but that does not seem to help because HttpGet is still not connecting! I am using IB Professional version 17.3.0

(31 Mar, 16:35) Anna_G

Also - not sure if it matters but I am using HttpGet from Validation Actions (to validate url and credentials entered by the user)

(31 Mar, 16:36) Anna_G

In addition to <enablesslsuport>1</enablesslsupport> the installer should be built with Full Build option.

(06 Apr, 12:46) Anna_G
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×7

Asked: 29 Mar, 13:07

Seen: 87 times

Last updated: 06 Apr, 12:46