Hi,

I've been trying to run my installer generated with InstallBuilder inside a Docker container (v0.6.1), but it doesn't work. It doesn't raise any error, but it exits immediately with the return code 1.

The installer is for a 64bit platform (linux-x64), my Docker "host" is 64bit and I've tried with both the ubuntu docker image and the centos one, but to no avavail.

I was wondering if the generated installer would have any dependency against some library which might not be present in those minimal Docker images? I tried to install the "Base" group on the CentOS image but it didn't help.

How can I debug this problem further?

Thanks.

Update: Some more debug info as suggested by wojciechka

  • Running with --help or --mode text doesn't help (same behavior)
  • Running ldd on the installer returns not a dynamic executable
  • strace doesn't give any specific error, but I'm not sure how to interpret the output. It doesn't seem fundamentally different from the output of a working installer. I've put the output here if that helps.

asked 30 Aug '13, 01:36

ngu's gravatar image

ngu
36113
accept rate: 0%

edited 30 Aug '13, 09:28


The issue seems to be related to aufs filesystem being used for /tmp. InstallBuilder will have handling for this specific issue to avoid customers running into the problem in its next release.

A workaround is to mount /tmp as tmpfs and run the installer afterwards - such as:

host# docker run -privileged -i -t container_name docker# mount none /tmp -t tmpfs docker# ./installer.run

link

answered 17 Oct '13, 05:09

wojciechka's gravatar image

wojciechka ♦♦
7.8k61122
accept rate: 26%

1

Thanks for the workaround!

Just for the record, for others who would want to follow-up on the AUFS bug, Wojciech has filed the bug report against AUFS here: http://sourceforge.net/p/aufs/bugs/19/

(17 Oct '13, 11:40) Gurjeet

Thanks, that worked.

(18 Oct '13, 05:24) ngu

Does it work properly if run with --mode text or --help appended?

Can you check if running ldd reports any missing libraries? If not, can you also run strace ./application-linux-x64-installer.run and check for any errors?

link

answered 30 Aug '13, 07:06

wojciechka's gravatar image

wojciechka ♦♦
7.8k61122
accept rate: 26%

Thanks for the suggestions! Funnily, I already tried all them all before posting, I guess I should have described that in the question. I'll update it.

(30 Aug '13, 08:47) ngu

Could you send us the project to support@bitrock.com?

(02 Sep '13, 07:30) juanjo ♦♦

I am having the same problem. The strace log is uploaded here http://uploads.enterprisedb.com/download.php?file=3e4cb4e8cc593b83fbf3a60f7a51b595

Any help will be greatly appreciated.

ldd output says 'not a dynamic executable'

(27 Sep '13, 16:09) Gurjeet

Could you write us to support@bitrock.com with the debugtace? You can generate it by executing:

installer.run --debugtrace debug.txt
(30 Sep '13, 03:25) juanjo ♦♦

Please see the shell session below:

[xdb@083cbbdb2f94 ~]$ ./xdbreplicationserver-5.1.0-beta1-2-linux-x64.run --debugtrace /tmp/debug.txt
[xdb@083cbbdb2f94 ~]$ echo $?
1
[xdb@083cbbdb2f94 ~]$ cat /tmp/debug.txt
cat: /tmp/debug.txt: No such file or directory
[xdb@083cbbdb2f94 ~]$ ./xdbreplicationserver-5.1.0-beta1-2-linux-x64.run --mode text --debugtrace /tmp/debug.txt
[xdb@083cbbdb2f94 ~]$ echo $?
1
[xdb@083cbbdb2f94 ~]$ cat /tmp/debug.txt
cat: /tmp/debug.txt: No such file or directory
[xdb@083cbbdb2f94 ~]$
(30 Sep '13, 13:55) Gurjeet
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×73
×4
×1

Asked: 30 Aug '13, 01:36

Seen: 7,264 times

Last updated: 18 Oct '13, 05:24