We have been using the bitrock autoupdater to allow our software to be update when ever there is a new version. While the code work perfectly ok with Windows XP and Windows 7, we are getting the following behavior from Vista users:

Problem: when opening Ubuntu One a small window that says "autoupdate-windows" pops up. Nothing is visible in the window. Upon closing the window (by clicking X in the upper right corner), a message box says a "new update is available," and asks if I want to update.

If I choose "No," the message box appears a second time. Upon closing the second time, nothing occurs.

If I choose "Yes," the message box disappears and the mouse cursor spins for a few seconds then returns to normal. Shortly thereafter the original autoupdate-windows box appears. Clicking X in the upper right corner then closes the box.

This cycle occurs everytime the user wants to update the application.

Is this a known issue of the autoupdater? Is the anything we can do about it or should we write our own code? The original bug reported by our Vista users can be found here.

asked 03 Nov '11, 07:46

mandel's gravatar image

mandel
6113
accept rate: 0%

Does this happen also in Windows 7 and XP or is it specific to Vista? Is this happening in multiple machines? Is it a 64bit system? Could you also add some images about the displayed windows?

(03 Nov '11, 08:18) juanjo ♦♦

I installed ubuntu one, on vista, for the first time yesterday and have the same exact symptoms including the program not appearing in "Programs and Features" under "Control Panel". So I can't do an uninstall and reinstall to attempt to solve the issue that way.

(03 Nov '11, 09:31) eeyore

We have checked it on Windows 7 and all worked perfectly. We will try to reproduce on Vista. Regarding the uninstallation, we also have the ARP menu entry but you could also navigate to the installation directory and launch uninstall.exe (c:\\Program Files\\ubuntuone\\uninstall.exe)

(03 Nov '11, 10:46) juanjo ♦♦

There is a short cut "Uninstall Ubuntu One" that points to uninstall.exe in the same directory. The uninstall.exe file is not there.

Also, I tried to run "autoupdate-windows.exe" directly and got the following message "No update.ini file found at C:\Program Files\ubuntuone/update.ini

note: When autoupdate runs automatically on ubuntuone program launch, it pops up an empty window. The notification pop up of an available update comes upon closing the empty window.

(03 Nov '11, 11:00) eeyore

There is another autoupdate-windows.exe under dist/ folder. I don't know the internals of the ubuntuone installer so I'm not sure why it is duplicated :). Could you take an screenshot of the windows? Could you check if the empty window is from the autoupdate or from Ubuntu One itself?

(03 Nov '11, 11:31) juanjo ♦♦

running autoupdate.exe from the ./dist folder has the same effect as when it is run from ubuntu one launch.alt text

the following window shows up and then when "yes" is selected it just sits and spins. alt text

The following is from the update.ini file

[Update]
url = http://one.ubuntu.com/windows/update.xml
version_id = 201
check_for_updates = 1

The following is from the end of the install.log

Script stderr:

Creating Shortcut for Uninstall Ubuntu One
Creating Desktop Shortcut for Ubuntu One
Please reboot to finish upgrade.
Unable to find previous uninstaller at C:/Program Files/ubuntuone/uninstall.exe
Unable to find previous uninstaller at C:/Program Files/ubuntuone/uninstall.exe
Installation completed

Log finished 11/03/2011 at 08:49:18

The following is from revnos.txt under /data

ubuntu-sso-client: 799
ubuntuone-client: 1145
ubuntuone-control-panel: 235
ubuntuonw-windows-installer: 76

Let me know what else you may want.

I have noticed on other sites that when one right clicks on the ubuntuone logo the menu has a fair amount of options. The following is my right click menu.

alt text

(03 Nov '11, 12:09) eeyore

The screen is indeed from the AutoUpdate. So, the issue is reproducible from command line? If so, could you execute the below from an administrator cmd?:

set INITDEBUG=1

.\dist\autoupdate-windows.exe > debug.txt

And paste the contents of the generated file?

In addition, could you send us a link to the exact Ubuntu One installer you are using so we can try to reproduce it on our side?

(03 Nov '11, 12:24) juanjo ♦♦

Link to installer: https://one.ubuntu.com/download/windows/client

The following is from the details tab for the installer

alt text

Contents from debug.txt

Loading win32 couldn't load library "C:/Users/Bryan/AppData/Local/Temp/be29e7f1-71ae-4703-50cb-1d52be512f51/twapi-be29e7f1-71ae-4703-50cb-1d52be512f51.dll": A function specified in the import table could not be resolved by the system.  Windows is not telling which one, I'm sorry.

couldn't load library "C:/Users/Bryan/AppData/Local/Temp/be29e7f1-71ae-4703-50cb-1d52be512f51/twapi-be29e7f1-71ae-4703-50cb-1d52be512f51.dll": A function specified in the import table could not be resolved by the system.  Windows is not telling which one, I'm sorry.

couldn't load library "C:/Users/Bryan/AppData/Local/Temp/be29e7f1-71ae-4703-50cb-1d52be512f51/twapi-be29e7f1-71ae-4703-50cb-1d52be512f51.dll": A function specified in the import table could not be resolved by the system.  Windows is not telling which one, I'm sorry.
(03 Nov '11, 13:13) eeyore

Juanjo, as far as I know the only OS that has this issues is Vista. We have had several bug reports regarding the issue so I'm pretty sure that the issue is a general one and has nothing to do with the users machine.

(03 Nov '11, 13:55) mandel

Just to confirm the issue, the above debug file was created by launching the AutoUpdate from a cmd. And it only happens with the AutoUpdate under "dist", the other AutoUpdate binary just complains about a missing update.ini

Is the above correct? If so, could you copy dist/update.ini to ubuntuone main directory and check the AutoUpdate that was complaining about the missing ini file?

In addition, we may need to ask for more information such as the XML project so it may be better to keep working from our private support. Could you write us to support@bitrock.com?

(03 Nov '11, 14:01) juanjo ♦♦
showing 5 of 10 show all

Finally, we have been able to reproduce it. The problem is that there is a conflict with one of the dlls in the working directory (dist), MPR.dll. This is happening because dlls in the parent directory takes precedence. You can find more information here.

To solve the issue, you just have to unpack the autoupdte to a subdirectory of dist or to its own folder under ubuntuone (any location without the extra dlls).

link

answered 03 Nov '11, 14:42

juanjo's gravatar image

juanjo ♦♦
5.8k413
accept rate: 23%

Now for the silly question. What file do I unpack and/or where do I find it? Also, if the parent directory ( or install directory ) takes precedence, then there are no *.dll's in that directory. There is, however, an mpr.dll in the "win\system32" directory, which I guess would have priority.

(03 Nov '11, 15:45) eeyore

I was able to get the autoupdate to function if I ran it out of one of the rollback directories and copying the update.ini file to that sub-directory.

I could also get the autoupdate to function if I rename the mpr.dll to something else.

I am now still stuck with the issue of Ubuntu One not syncing from vista and that I cannot uninstall it, so I can try to re-install it, but I do not think that is an issue for this board.

(03 Nov '11, 16:20) eeyore

According to the messages in the log, the uninstaller is not being created because it is running in upgrade mode (configured using <installationtype>upgrade</installationtype>).

If you send us your XML project (for the installer) we will provide you with more specific instructions about how to configure it.

(03 Nov '11, 17:20) juanjo ♦♦
(03 Nov '11, 17:54) eeyore

Could you check if in your XML project the installation mode is not being set to "upgrade" when an existing installation is detected? In upgrade mode, no uninstaller is created, just the old one is updated (if it exists).

(03 Nov '11, 18:27) juanjo ♦♦

I have made a few checks on Windows Vista and when running autoupdate-windows.exe from dist directory, it does not start - when I removed MPR.dll, it did work.

I was also able to run autoupdate by simply copying update.ini from c:\Program Files\ubuntuone\dist to c:\Program Files\ubuntuone directory and running the binary from c:\Program Files\ubuntuone. autoupdate binary is already installed there.

Is it be possible to install autoupdate-windows.exe in main directory (...\ubuntuone) instead of ...\ubuntuone\dist and run it from there? It should resolve the autoupdate issue.

(04 Nov '11, 09:46) wojciechka ♦♦

I also verified when installing ubuntuone to an empty, but existing directory, the uninstaller is not created. As Juanjo said, the probable reason would be that you set installationtype to upgrade.

If this is the case, I would recommend you to do a check for uninstaller file and/or some key files - for example you can check for uninstaller by doing:

<fileexists> <path>${installdir}/${project.uninstallerName}.exe</path> </fileexists>

Could you send your installer's project XML to support@bitrock.com so we can take a look at it and potentially give advices about changing the behavior?

(04 Nov '11, 09:46) wojciechka ♦♦
showing 5 of 7 show all

Hello,

I have de same issue, after read this article i rename the autoupdate-windows.exe file located in C:\Program Files\ubuntuone\dist\ like 1_autoupdate-windows.exe_1 and then reboot the system, it's solved the problem in windows vista home.

see you ...

link

answered 10 Nov '11, 08:23

Slyer%20Mr's gravatar image

Slyer Mr
11
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×176
×22
×2

Asked: 03 Nov '11, 07:46

Seen: 2,281 times

Last updated: 10 Nov '11, 08:23