On Windows I package Windows, Mac and Linux versions of my product. I can copy the .app file to a Mac and install just fine. I can copy the .run file to a 32-bit Linux system (where I built the Linux code) and it runs, but if I copy the .run file to a 64-bit Linux system the installer doesn't run. No error, no dialogs, no nothing.

So I tried building my Linux code on a 64-bit version of Linux, copied that to my Windows system, ran InstallBuilder, and then copied the new .run file to the 64-bit Linux system. Same problem. When I run the .run file it just completes immediately with no dialogs and no errors. This same 64-bit version installs just fine on my 32-bit Linux system.

What am I doing wrong?

asked 01 Mar '12, 16:23

ColinBlake's gravatar image

ColinBlake
15567
accept rate: 0%


It seems that the installer is built as 32-bit binary (i.e. linux target, not linux-x64 target) and the OS does not have 32-bit compatibility libraries.

For Ubuntu/Debian, you can install ia32-libs and ia32-libs-gtk. For other systems, the package name may be different.

link

answered 01 Mar '12, 16:30

wojciechka's gravatar image

wojciechka ♦♦
7.8k61122
accept rate: 26%

How can I built a 64-bit version of the installer?

(01 Mar '12, 16:34) ColinBlake

You can set target to linux-x64 from command line or Linux x86 64 bits from GUI.

(01 Mar '12, 16:54) wojciechka ♦♦

Using a target of linux-x64 did the trick. Thanks.

(01 Mar '12, 17:04) ColinBlake
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×72
×5

Asked: 01 Mar '12, 16:23

Seen: 8,327 times

Last updated: 01 Mar '12, 17:04